TextbookX Intermittent Issues

Incident Report for VitalSource

Resolved

The incident has been resolved.
Posted Jul 07, 2026 - 19:20 EDT

Identified

The issue has been identified, and a fix is currently being implemented.
Posted Jul 07, 2026 - 19:15 EDT

Investigating

TextbookX is currently experiencing intermittent issues. The team is investigating.
Posted Jul 07, 2026 - 18:41 EDT
This incident affected: Akademos TextbookX.