VitalSource Analyze Down

Incident Report for VitalSource

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 18:37 EDT

Monitoring

Analyze has recovered. We are monitoring.
Posted Jun 12, 2025 - 17:50 EDT

Identified

The VitalSource Analyze applications are unavailable due to ongoing major disruptions from our upstream cloud providers.
Posted Jun 12, 2025 - 16:12 EDT
This incident affected: Analytics.